找回密码
 立即注册

QQ登录

只需一步,快速开始

铁威马网络网络存储

[教程分享] DLNA切换上传Twonky-DEB固件包出现【31101-无效的固件包】的解决方案

  [复制链接]
本帖最后由 mojelly 于 2014-12-9 12:37 编辑

Mybooklive 出厂时的媒体软件,有的自带DLNA流媒体,

有的则是Twonky,


个人感觉Twonky更强大(笔者第一个MBL原厂自带Twonky),特别是新版的可玩性比较高,可以在webui界面推送媒体文件(视频、音乐、图片)到各个支持AirPlay的设备,比如,优酷XL、XBMC、天猫魔盒、小米电视、盒子等……


在UI界面上传DEB固件,从DLNA切换到Twonky出现【31101-无效的固件包】报错的现象
      




经过笔者多次折腾,得到的初步判断,可能是deb上传之后解包,找不到正确的文件路径所产生的报错


笔者当时为了给自己组装的MBL安装Twonky时也遇到同样问题,瞎折腾之后搞定了此问题,但是具体是哪一步正确了,却无法查证,好在10月份的时候折腾KODexplorer 修改PHP导致不能登录账户问题【解决方法见笔者帖子】时又给了一次折腾的机会,重装3后又无意搞定了问题,这次注意了每一次的步骤,找到了正确的方法(感谢爆爆今天又亲自测试,以确认方法的准确性!)


以下为解决方法:
游客,如果您要查看本帖隐藏内容请回复



哎呀呀~又要加精了,赶脚发的每一篇帖子都挺精的,又可以骗云朵、碎银、金块了~

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x

评分

参与人数 2云币 +5 金条 +10 碎银 +18 收起 理由
good69395 + 2 + 5 + 10
爆疯语 + 3 + 5 + 8 有图有真相啊!!好牛逼!又解决了世界性难.

查看全部评分

使用道具 举报 回复
好强大啊好强大啊
使用道具 举报 回复 支持 反对
终于有大神出现了,非常感谢
使用道具 举报 回复 支持 反对
本帖最后由 售后服务 于 2014-12-9 13:09 编辑


老大,还是不行啊,下面是log
updateFirmwareFromFile.sh:12/09/14 05:05:09:upgrade start: /CacheVolume/Twonky5MediaServerPatch.deb
updateFirmwareFromFile.sh:12/09/14 05:05:09:check_size=
updateFirmwareFromFile.sh:12/09/14 05:05:09:version_current=024303022
updateFirmwareFromFile.sh:12/09/14 05:05:09:version_newfile=010001
updateFirmwareFromFile.sh:12/09/14 05:05:09:package_newfile=apnc-twonky
updateFirmwareFromFile.sh:12/09/14 05:05:09:master_package_name=apnc
updateFirmwareFromFile.sh:12/09/14 05:05:09:master_package_new=apnc
updateFirmwareFromFile.sh:12/09/14 05:05:09:update_container=twonky
(Reading database ...
dpkg: warning: files list file for package `ramlog' missing, assuming package has no files currently installed.

dpkg: warning: files list file for package `libparted0' missing, assuming package has no files currently installed.
18653 files and directories currently installed.)
Unpacking apnc-twonky (from .../Twonky5MediaServerPatch.deb) ...
preinst: currentRootDevice=/dev/md1
preinst: master_package_name=apnc
preinst: update_container=twonky
Install not supported
dpkg: error processing /CacheVolume/Twonky5MediaServerPatch.deb (--install):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/CacheVolume/Twonky5MediaServerPatch.deb
updateFirmwareFromFile.sh:12/09/14 05:05:10:failed 200 "invalid firmware package"
Error fw_update_status: failed 200 "invalid firmware package"



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
使用道具 举报 回复 支持 反对
本帖最后由 售后服务 于 2014-12-9 13:07 编辑

网络延时,发重了,不好意思.
使用道具 举报 回复 支持 反对
本帖最后由 售后服务 于 2014-12-9 13:06 编辑

发重了,不好意思
使用道具 举报 回复 支持 反对
谢谢分享,多多学习
使用道具 举报 回复 支持 反对
百度新脚本【飞提供地址】
使用道具 举报 回复 支持 反对
多谢宝宝分享
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 搜索 官方QQ群