找回密码
 立即注册

QQ登录

只需一步,快速开始

快捷登录

铁威马网络网络存储

1

精华

172

帖子

308

积分

技术达人

Rank: 6Rank: 6

云币
9
贡献
620
活跃
71
精华
1

NAS发烧友技术达人

QQ

[教程分享] WD MyCloud安装openmediavault_1.0.23

[复制链接]
出处:http://www.nasyun.com/thread-23758-1-1.html

我的方法是拆机挂电脑上安装,没拆机的同学请绕行,自行解决
凡事有风险请注意

rootfs.img下载地址:http://pan.baidu.com/s/1o60s9V8
下载里面的WD My Cloud>MyCloud_Debian>openmediavault_1.0.23>debian_wheezy_omv_1.0.23.zip


debian_wheezy_omv_1.0.23.zip用7ZIP软件一个个解压缩出来,最后得到一个rootfs.img文件。
按恢复WD固件的方法来弄就行:http://www.nasyun.com/thread-23346-1-1.html

下载一个WinHex_17.8_SR7汉化版(百度很多),右键管理员身份运行WinHex.exe。点击菜单,文件--打开--rootfs.img。
打开后一推16进制数字,不要管他,菜单--专业工具--将镜像文件转换为磁盘。可以看到文件夹了。

然后菜单--打开磁盘--选择物理驱动器--你的mc硬盘。然后可以看到MC硬盘里面有很多分区。我们要用的到就是2个1.9G的分区,也是那2个没有分区盘符的。我这里的顺序是第2个分区和第3个分区,分别点击打开。


第四步,这里在WinHex里面应该有4个页面,一个rootfs.img,一个MC硬盘,二个1.9G的分区。
关键的来了,我们要打开菜单--工具--磁盘工具--磁盘克隆。

源盘位置选择rootfs.img(1.9GB),目标位置选择逻辑驱动器里面的2个1.9GB分区之一(2个都要刷,顺序无所谓),起始扇区选择0.其他都默认,确认开始复制。跳出的框都确认即可。完成后把另一个1.9GB的分区也刷一遍。





然后接好板子与电源还有网线
启动后绿灯即正常

用户名/密码:  ssh: root/mycloud (openmediavault web界面登录: admin/mycloud)


先别着急按插件

在SSH下
先更新点东西

分别输入下面命令
apt-get update
apt-get upgrade


更新到最新
然后到界面中的更新管理器里把所有的更新完毕

好了现在可以安装插件了!
有些插件不能用请看我的服务里面安装的
经反复拆机验证都可以用
其他待发现
有的安装后不兼容可导致系统奔溃,请注意



小伙伴们看到服务里的插件,心动没,心动就马上行动,我将继续整理所有安装过程中注意到的与用SSH安装的部分等使用截图
特别感谢“一段香”
帮助我很多。





本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
楼主热帖
那是云论坛 - 国内最开放NAS交流平台
http://www.nasyun.com
使用道具 举报 回复 印象
无线音乐盒
好牛逼!等有空就刷一个
那是云论坛 - 国内最开放NAS交流平台
http://www.nasyun.com
使用道具 举报 回复 支持 反对 印象
ssh登录后俄文问题update和upgrade能解决不?
使用道具 举报 回复 支持 反对 印象
SSH下输入
dpkg-reconfigure locales
编码选英文
en_us.UTF-8 UTF-8

·zh_CN.GBK GBK
·zh_CN.UTF-8 UTF-8

自己设置吧!
那是云论坛 - 国内最开放NAS交流平台
http://www.nasyun.com
使用道具 举报 回复 支持 反对 印象
jz1024 发表于 2015-3-22 11:32
SSH下输入
dpkg-reconfigure locales
编码选英文

我知道可以这么设,但是我设了重启又变回俄文了- -
使用道具 举报 回复 支持 反对 印象
好吧。。。我自己找的方法了。。。修改/etc/default/locale,改成LANG=en_US.UTF-8重启OK
使用道具 举报 回复 支持 反对 印象
设置一样
不用修改文件的
那是云论坛 - 国内最开放NAS交流平台
http://www.nasyun.com
使用道具 举报 回复 支持 反对 印象
心动啊,晚上回家折腾!
那是云论坛 - 国内最开放NAS交流平台
http://www.nasyun.com
使用道具 举报 回复 支持 反对 印象
刷完了插上电源和网线,灯一直是白色的,不变蓝啊,怎么破?重刷?
那是云论坛 - 国内最开放NAS交流平台
http://www.nasyun.com
使用道具 举报 回复 支持 反对 印象
重启一下!拔电源,应该等会就好了!
那是云论坛 - 国内最开放NAS交流平台
http://www.nasyun.com
使用道具 举报 回复 支持 反对 印象
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 搜索 官方QQ群