找回密码
 立即注册

QQ登录

只需一步,快速开始

铁威马网络网络存储

[教程分享] 二条命令4.x降级到3.0固件(综合经验贴)

  [复制链接]
本帖最后由 jz1024 于 2015-4-20 13:17 编辑

*所有降级都有风险,请注意备份好资料

游客,如果您要查看本帖隐藏内容请回复



注意执行命令顺序,不能颠倒,请按步骤来操作
有的帖子中写
进入设置→固件→自动更新 关闭自动更新(好像自动是关闭的,可以看一下!是否关闭。)


也可以手动下载固件降级,请看这个帖子
04.01.03-421降级到03.03.01-230(百分百能降级成功)

不会进ssh的请留言,以后会继续写详细图文教程


降级到3.0后还原一下整个系统,防止发生任何问题,具体在web管理设置里面有设置(选仅系统)。
有的显示容量不正确,请等待系统扫描(根据你资料的多少来决定扫描的时间,把媒体那关闭,减少扫描时间)
重新启动系统,基本都可以恢复正常。




评分

参与人数 1云币 +2 金条 +5 碎银 +8 收起 理由
爆疯语 + 2 + 5 + 8 用技术拯救世界!

查看全部评分

使用道具 举报 回复
本帖最后由 yumin9822 于 2015-4-21 11:43 编辑

看看lz是怎么实现的!发现LZ的第一个脚本有问题。
  1. wget http://download.wdc.com/nas/sq-040000-607-20140630.deb -O /DataVolume/shares/Public/sq-040000-607-20140630.deb
  2. echo "02.02.02-111" >/etc/version;
  3. cd /DataVolume/shares/Public/
  4. chmod +x sq-030401-230-20140415.deb
  5. dpkg -i /DataVolume/shares/Public/sq-030401-230-20140415.deb
复制代码

觉得应该是
  1. wget http://download.wdc.com/nas/sq-040000-607-20140630.deb -O /DataVolume/shares/Public/sq-040000-607-20140630.deb
  2. echo "02.02.02-111" >/etc/version;
  3. cd /DataVolume/shares/Public/
  4. chmod +x sq-040000-607-20140630.deb
  5. dpkg -i /DataVolume/shares/Public/sq-040000-607-20140630.deb
复制代码
其实理论上只要运行第二个脚本就可以,实现降级到3.0,不知道为什么需要先降到4.0.

推荐如下:
  1. wget http://download.wdc.com/nas/sq-030401-230-20140415.deb -O /DataVolume/shares/Public/sq-030401-230-20140415.deb
  2. echo "02.02.02-111" > /etc/version
  3. dpkg -i /DataVolume/shares/Public/sq-030401-230-20140415.deb
复制代码

over


使用道具 举报 回复 支持 反对
yumin9822 发表于 2015-7-13 10:54
cd /DataVolume/shares/Public/
chmod +x sq-030401-230-20140415.deb
这两句诗多余的

我也不明白楼主的意思,既然是4.X-4.0 4.0-3.0,那么下载了4.0固件却不去执行它,把它解压到了public目录,修改了一遍一个不存在的3.0固件的文件属性,再下载3.0固件也解压了过去,再修改,那么下载这个4.0固件的意义是什么?不小心升级5.0的时候先降4.0用?太未雨绸缪了吧?荒谬!
使用道具 举报 回复 支持 反对
给最近新入手的朋友一个提醒:我也是前两天刚入手的mycloud 3T版,出厂大概是4.02以上版本(因为现已降级,记不清了),初次连接WinSCP一直连不上,显示mycloud不是sftp标准设备,一直搞不清状况,后来用putty连上,发现提示要求修改root初始密码,改完密码WinSCP就连上了
使用道具 举报 回复 支持 反对
用技术拯救世界!
使用道具 举报 回复 支持 反对
谢谢楼主分享
使用道具 举报 回复 支持 反对
不知不觉的自动又升级成4.0了
使用道具 举报 回复 支持 反对
yumin9822 发表于 2015-4-21 11:29
看看lz是怎么实现的!发现LZ的第一个脚本有问题。

觉得应该是

是这样的!4.X的机制在4.0处是个中点然后就是3.0,直接从64K降级怕有错误!我只是写全点而已呵呵!以后出5.0或是6.0呢!一个版本一个版本的降级而已。
使用道具 举报 回复 支持 反对
fox1952 发表于 2015-4-21 21:54
不知不觉的自动又升级成4.0了

注意执行命令顺序,不能颠倒,请按步骤来操作

进入设置→固件→自动更新 关闭自动更新(好像自动是关闭的,可以看一下!是否关闭。)
使用道具 举报 回复 支持 反对
好东西,试试。
使用道具 举报 回复 支持 反对
试试看,是否有效
使用道具 举报 回复 支持 反对
学习中,我也想试试
使用道具 举报 回复 支持 反对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 搜索 官方QQ群